编译 openwrt 及初始配置-及部分排错

王先生
2023-11-01 / 0 评论 / 32 阅读 / 正在检测是否收录...

参考上篇,搭建命令行代理

克隆
git clone https://github.com/openwrt/openwrt.git

逐条输入下列命令(及时验证是否安装成功):

sudo apt-get install g++

sudo apt-get install libncurses5-dev

sudo apt-get install zlib1g-dev

sudo apt-get install bison

sudo apt-get install flex

sudo apt-get install unzip

sudo apt-get install autoconf

sudo apt-get install gawk

sudo apt-get install make

sudo apt-get install gettext

sudo apt-get install gcc

sudo apt-get install binutils

sudo apt-get install patch

sudo apt-get install bzip2

sudo apt-get install libz-dev

sudo apt-get install asciidoc

sudo apt-get install subversion

sudo apt-get install sphinxsearch

sudo apt-get install libtool

sudo apt-get install sphinx-common

sudo apt install git
gcc 要求 4.8 以上

./scripts/feeds update -a
错误1:
fatal: unable to access 'https://git.openwrt.org/feed/telephony.git/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
新的 ca curl 不认识。
解决方法:
export GIT_SSL_NO_VERIFY=1
或者
sudo apt-get update
sudo apt-get install ca-certificates
错误2
Build dependency: Please install the GNU C Compiler (gcc) 8 or later
Build dependency: Please reinstall the GNU C Compiler (8 or later) - it appears to be broken
Build dependency: Please install the GNU C++ Compiler (g++) 8 or later
Build dependency: Please reinstall the GNU C++ Compiler (8 or later) - it appears to be broken
Build dependency: Please install Python >= 3.7
Build dependency: Please install Python >= 3.7
Build dependency: Please install the Python3 distutils module
Build dependency: Please install the Python3 stdlib module
不能在使用 ubuntu 16.0.4 编译了,改用 ubuntu 20.0.4 可以正常编译

./scripts/feeds install -a

配置
make menuconfig

选择

评论 (0)

取消